using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\$?(\d+(?:\s\d+)*(?:[\.\,]\d{1,2})?)\s?\$?$";
string input = @"12,00$
122.04$
12123123
1 200$
1 200,22$";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}