package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@delim(.+?)@delim`)
var str = `@delimabc@delim@delim123@delim@delim456@delim`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}