$re = '/<\/h2>(.*?)</';
$str = '<h2>my title here</h2>Lorem ipsum dolor sit amet<h2>my title here</h2>consectetur adipisicing elit quod tempora';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);