$re = '/((([.A-Z0-9!#$%&\'*+/=?^_`{|}~-])+@([.A-Z0-9!#$%&\'*+/=?^_`{|}~-])+\.[A-Z]{2,13})((,\s)?))/i';
$str = 'asd@asd.qwe, asdqwe@asd.qwe, asd@asd.qwe, ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);