const regex = /^(?:(?!global\.css$).)*\.css$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?!global\\.css$).)*\\.css$', 'gm')
const str = `test.test.css
test.css
test.global.css
test.css
test.test.css
test.global.test.css
test.global.test.test.global.css
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}