import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/test1/test2/(?!new\\.jpg).*";
final String string = "/test1/test2/a.png\n"
+ "/test1/test2/b.png\n"
+ "/test1/test2/new.jpg\n"
+ "/test1/test2/c.png";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}