re = /([A-Z]{3})=(.*)+/i
str = 'ABC=TEXT 1 - HERE.. DEF=/TEXT 2: TEXT .. ZYX=TEXT 3 TEXT'
# Print the match result
str.match(re) do |match|
puts match.to_s
end