$re = '/(?<cod_prog>[1-9]\d*)\.(?<num_avv>[1-9]\d*)/';
$str = '123.456';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);