$re = '/((\d)\2*)/';
$str = '11122233344456
223334456111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);