import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9!#$%&'*+/=?^_`\\{|\\}~-]+(?:\\.[a-z0-9!#$%&'*+/=?^_`\\{|\\}~-]+)*@(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\\.){1,3}[a-z0-9](?:[a-z0-9-]*[a-z0-9])?$";
final String string = "wiliam@hotmail.com\n"
+ "wiliam.ferraciolli@hotmail.com\n"
+ "wiliam@hotmail.co.uk\n"
+ "wiliam.ferraciolli@hotmail.co.uk\n"
+ "wiliam_ferraciolli@hotmail.co.uk\n"
+ "wiliam'ferraciolli@hotmail.co.uk\n"
+ "wiliam334-1@mydomain.co.uk.me\n\n"
+ "wiliam.ferraciolli@hotmail.com.dodge.too.many\n"
+ "hwiliam@hotmail.com.otherdomain.uk.dodge\n"
+ "wiliam.ferraciolli@hotmail.com.com.com.com\n"
+ "wiliam.hotmail.com\n"
+ "wiliam..ferraciolli@hotmail.com\n"
+ "wiliam%ferraciolli.@hotmail.com\n"
+ "wiliam$ferraciolli.@hotmail.com\n"
+ "wiliam/ferraciolli.@hotmail.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}