use strict;
my $str = '120.65UAH Produkti Kvartal
5*34 14:24
Bal. 16603.52UAH
120.65UAH Produkti Kvartal
5*14 14:24
Bal. 16603.52UAH
120.65UAH Produkti Kvartal
5*14 14:24
Bal. 11111.52UAH';
my $regex = qr/(?=5\*14)[\s\S]*?(\d{5}\.\d{2})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}