$re = '/!\[([^]]*)]\([^\/]*\/([^)]*)\)/m';
$str = '1. This is some content

2. This is some other content )/user_registered.png)';
$subst = "{% asset_img \2 \1 %}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;