use strict;
my $str = '12345-1234';
my $regex = qr/^(\d{5})-?\d{4}$/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";