using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)";
string input = @"1.2.3.4
23.2222.87.9
23.223.011.133
12.159.46.200
12.253.789.2
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}