$re = '/\[\[(.*?)]]/';
$str = '[[match this]] and this [[match that]], too.';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;