import Foundation
let pattern = #"(netstat\s*\/(a|n|o|b){1,4})|(netstat\s+-(a|n|o|b){1,4})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
netstat -anob
netstat -ano
netstat -anob
netstat -ano
netstat /anob
netstat /ano
netstat /anob
netstat /ano
netstat/anob
netstat/ano
netstat /anob
netstat /ano
netstat -a
netstat -an
netstat /a
netstat /an
netstat /ona
netstat /bona
netstat /nob
netstat /noba
netstat /onab
netstat /noba
netstat /abon
netstat /abn
netstat /anb
netstat-anob
netstat-ano
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)