#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)"
Local $sString = "[::1]" & @CRLF & _
"[:a:1]" & @CRLF & _
"[:bh:lh:1]" & @CRLF & _
"[1:1:fEd1:1:abdc:1]" & @CRLF & _
"[::ffff:192.0.2.128]" & @CRLF & _
"[0000:0000:0000:0000:0000:0000:0000:0001]" & @CRLF & _
"[2001:0db8:0000:0000:0000:ff00:0042:8329]" & @CRLF & _
"[2001:db8:0:0:0:ff00:42:8329]" & @CRLF & _
"[2001:db8::ff00:42:8329]" & @CRLF & _
"[2001:0db8:0000:0000:0000:ff00:0042:8329]" & @CRLF & _
"" & @CRLF & _
"::1" & @CRLF & _
":a:1" & @CRLF & _
":bh:lh:1" & @CRLF & _
"1:1:fEd1:1:abdc:1" & @CRLF & _
"::ffff:192.0.2.128" & @CRLF & _
"0000:0000:0000:0000:0000:0000:0000:0001" & @CRLF & _
"2001:0db8:0000:0000:0000:ff00:0042:8329" & @CRLF & _
"2001:db8:0:0:0:ff00:42:8329" & @CRLF & _
"2001:db8::ff00:42:8329" & @CRLF & _
"2001:0db8:0000:0000:0000:ff00:0042:8329" & @CRLF & _
"" & @CRLF & _
"United Kingdom , London" & @CRLF & _
"IP: 91.149.202.91" & @CRLF & _
"IPv6: 2605:e440:8::2:1b" & @CRLF & _
"http://91.149.202.91/1000MB.test" & @CRLF & _
"http://[2605:e440:8::2:1b]/1000MB.test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")