// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/[A-Z]?[a-z]{1,3}[0-9]?\.exe$").unwrap();
let string = "hxxp://mnmassagetherapy[.]com/wp-content/uploads/2016/04/lib.exe
hxxp://seed-bc[.]com/juop4/plwr/mklo/rbn/jan2.exe
hxxp://15.204.49[.]148/files/Had.exe
hxxp://hugo.topteamlife[.]com/order/tuc5.exe";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}