re = /From.*/
str = 'Vans model 10 . 390 From Random Data
Nike model 982 . Errant From Default Data
Timberland old school From Whatever'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result