$re = '/^[\-_A-Z0-9\,\.\@]*$/i';
$str = 'jim.jones@trivantis.com,foo.bar@baz.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);