#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mix)^(?=.*a)(?=.*b)[abc]*$"
Local $sString = "dabc" & @CRLF & _
"fbca" & @CRLF & _
"cab" & @CRLF & _
"bac" & @CRLF & _
"acb" & @CRLF & _
"cba" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)