$re = '/(?<=\d)[[:blank:]]+(?!$)|[[:blank:]]+(?=\d)/m';
$str = '708 447 4797 JOHN SMITH 18000
708 447 4797 JOHN SMITH 18000
708 447 4797 JOHN SMITH 18000
708 -3.00 4797 JOHN SMITH 18000';
$subst = "|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;