using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((?:[^)(]|(?R))*\)";
string input = @"(2*x^2 + 5*x - (2*x - 3)^(1/2))/(1 + x)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}