$re = '/\((?:[^)(]|(?R))*\)/';
$str = '(2*x^2 + 5*x - (2*x - 3)^(1/2))/(1 + x)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);