// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\((?:[^)(]|(?R))*\)").unwrap();
let string = "(2*x^2 + 5*x - (2*x - 3)^(1/2))/(1 + x)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}