const regex = /^(\s{0,})(\d{2}\/\d{2}\/\d{4})(,\d{2}\/\d{2}\/\d{4}){1,}(\s){0,}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\s{0,})(\\d{2}\\\/\\d{2}\\\/\\d{4})(,\\d{2}\\\/\\d{2}\\\/\\d{4}){1,}(\\s){0,}$', '')
const str = `10/03/1962,11/07/1986,24/06/2015,24/06/2015,12/12/2010,23/08/2010,13/06/2027`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}