const regex = /^(?:(\+[0-9]{1,3})[ -])?\(?\d{3}\)?[- ]?\d{3}[- ]?\d{4}/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(\\+[0-9]{1,3})[ -])?\\(?\\d{3}\\)?[- ]?\\d{3}[- ]?\\d{4}', 'igm')
const str = `1234567890
123-456-7890
(123)456-7890
123 456 7890
+1 123 456 7890
+123 123 456 7890
+1234 123 456 7890
+23 (123) 456-7890
+23 (123) 123-456-7890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}