import Foundation
let pattern = #"^(?:(\+[0-9]{1,3})[ -])?\(?\d{3}\)?[- ]?\d{3}[- ]?\d{4}"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
1234567890
123-456-7890
(123)456-7890
123 456 7890
+1 123 456 7890
+123 123 456 7890
+1234 123 456 7890
+23 (123) 456-7890
+23 (123) 123-456-7890
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)