// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b([0-1]+)\b").unwrap();
let string = "101";
let substitution = "0$1~010";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}