using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d*)(?: ?до| руб\.) (\d*)(?: руб\. )?\/ (ч|\d+)";
string input = @"от 1100 руб. / ч
до 1900 руб. / 45 мин.
от 1200 до 1900 руб. / 90 мин. ";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}