use strict;
my $str = ':asdf:ghkl:zxcv:';
my $regex = qr/(:([^:]*:){2})$/p;
my $subst = ':';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";