$re = '/\{?(?<key>.*?):(?<val>["].*["]?|.*?)[,\W]\}?/';
$str = '{1:aa,2:bb,3:"aa:bb"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);