# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/blog\/([0-9]{4})\/(.*)/\/$1/gm;t' <<< "https://www.mcb-bank.com/business/products/business-customer-account-information"