#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)blog/([0-9]{4})/(.*)"
Local $sString = "https://www.mcb-bank.com/business/products/business-customer-account-information"
Local $sSubst = "/$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)