import Foundation
let pattern = #"blog/([0-9]{4})/(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"https://www.mcb-bank.com/business/products/business-customer-account-information"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)