$re = '/^([[:digit:]]{3}\.?){3}(\-|\.)[[:digit:]]{2}$/m';
$str = '821.446.257-15';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);