use strict;
my $str = 'def sample_function1(arg1, arg2):
result = arg1 + arg2
if result > 10:
print("Greater than 10")
else:
print("Not greater than 10")
return result
def sample_function2(arg1, arg2):
result = arg1 - arg2
if result < 0:
print("Negative result")
else:
print("Non-negative result")
return result
def sample_function3(arg1,
arg2):
result = arg1 + arg2
if result > 10:
print("Greater than 10")
else:
print("Not greater than 10")
return result
class SampleClass1:
def __init__(self, arg1, arg2):
self.arg1 = arg1
self.arg2 = arg2
def sample_method1(self):
result = self.arg1 + self.arg2
return result
class SampleClass2:
def __init__(self,
arg1,
arg2):
self.arg1 = arg1
self.arg2 = arg2
def sample_method1(self):
result = self.arg1 + self.arg2
return result
';
my $regex = qr/(?P<function>def\s+(?P<function_name>\w+)\s*\((?P<parameters>(?:.|\n)*?)\):\s*(?:\n[ \t]+.*?)*\n)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}