$re = '/(\d{9}) (\d{5})/m';
$str = '123456789 12345678
12345678 12345
123456789 123456
123456789 12345
123456789 AZERT';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;