import Foundation
let pattern = #""\d+""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"1" : 12,
"2" : 24,
"3" : 36,
"4" : 44,
"5" : 138,
"6" : 195,
"7" : 127,
"8" : 91,
"9" : 52,
"10" : 45,
"11" : 21,
"12" : 15
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)