#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\(\s*(.*)\)"
Local $sString = "node " & @CRLF & _
"" & @CRLF & _
" ( t-ur0wkjqky55s9mlh2rtt0u30r ) {" & @CRLF & _
" text ("[g:token.dice.Sum] roll the dice with (6)[v:token.dice.NumSides] sides (3)[v:token.dice.NumDice] times")" & @CRLF & _
" plan (Y2Bl4CnLLNNLyUxO1QsuzWUQhvOC8nNyglKLS3NKGARRBF2ADAYBuJBfaS5YRBBZJDgzJbWYgYWBkYGJgRlIM4BZIMjIAAHMYAyUAQA= )" & @CRLF & _
"}" & @CRLF & _
"node (t-vr0wkjqky55s9mlh2rtt0u301 ) {" & @CRLF & _
" text ("[g:token.dice.Sum] boll tha dice with (6)[v:token.dice.NumDice] side (3)[v:token.dice.NumSides] times" )" & @CRLF & _
" plan ( Y2Bl4CnLLNNLyUxO1QsuzWUQhvOC8nNyglKLS3NKGARRBF2ADAYBuJBfaS5YRBBZJDgzJbWYgYWBkYGJgRlIM4BZIMjIAAHMYAyUAQA=)" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")