// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\(\s*(.*)\)").unwrap();
let string = "node
( t-ur0wkjqky55s9mlh2rtt0u30r ) {
text (\"[g:token.dice.Sum] roll the dice with (6)[v:token.dice.NumSides] sides (3)[v:token.dice.NumDice] times\")
plan (Y2Bl4CnLLNNLyUxO1QsuzWUQhvOC8nNyglKLS3NKGARRBF2ADAYBuJBfaS5YRBBZJDgzJbWYgYWBkYGJgRlIM4BZIMjIAAHMYAyUAQA= )
}
node (t-vr0wkjqky55s9mlh2rtt0u301 ) {
text (\"[g:token.dice.Sum] boll tha dice with (6)[v:token.dice.NumDice] side (3)[v:token.dice.NumSides] times\" )
plan ( Y2Bl4CnLLNNLyUxO1QsuzWUQhvOC8nNyglKLS3NKGARRBF2ADAYBuJBfaS5YRBBZJDgzJbWYgYWBkYGJgRlIM4BZIMjIAAHMYAyUAQA=)
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}