using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)<img[^>]*>(*SKIP)(*F)|\bNavigation\b";
string input = @"Navigation
<img src=""Navigation.jpg"" />
Navigation
<img src=""Navigation.jpg"" />
<b>Navigation</b>
<img src=""Navigation"" />
Navigation
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}