re = /(?i)<img[^>]*>(*SKIP)(*F)|\bNavigation\b/
str = 'Navigation
<img src="Navigation.jpg" />
Navigation
<img src="Navigation.jpg" />
<b>Navigation</b>
<img src="Navigation" />
Navigation
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end