using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"lorem[\s\S]*ipsum|ipsum[\s\S]lorem";
string input = @"Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}