#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\[[0-9]*]:)(.*)\r?\n?"
Local $sString = "this is a [link][1]" & @CRLF & _
"[1]: http://example.com" & @CRLF & _
"and this is a [good website][2] in my opinion" & @CRLF & _
"[2]: http://goodwebsite.com" & @CRLF & _
"[3]: http://example.com/fsadf.jpg" & @CRLF & _
"[![this is a photo][3]][3]" & @CRLF & _
"and there is some text hare ..!"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)