const regex = /^(\[[0-9]*]:)(.*)\r?\n?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\[[0-9]*]:)(.*)\\r?\\n?', 'gm')
const str = `this is a [link][1]
[1]: http://example.com
and this is a [good website][2] in my opinion
[2]: http://goodwebsite.com
[3]: http://example.com/fsadf.jpg
[![this is a photo][3]][3]
and there is some text hare ..!`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);