import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(t(?:\\w{4})\\d{3})\\b";
final String string = "SELECT tcmcs003.*, tccom130.nama, tccom705.dsca, tcmcs052.dsca, tccom100.nama \n"
+ "FROM tcmcs003, tccom130,tccom705,tcmcs052,tccom100 \n"
+ "WHERE tcmcs003.cadr REFERS TO tccom130 \n"
+ " AND tcmcs003.casi REFERS TO tccom705 \n"
+ " AND tcmcs003.cprj REFERS TO tcmcs052 \n"
+ " AND tcmcs003.bpid REFERS TO tccom100 \n"
+ "ORDER BY tcmcs003._index1";
final String subst = "$1XXX";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}