import re
regex = re.compile(r"^(([A-Z]+)[-_])?(\w+.SV)$", flags=re.MULTILINE)
test_str = ("TRND-0LL2134.SV\n"
"TRN_RTXDFT.SV\n"
"TRND_ZRSFTFF.SV\n"
"DR3345.SV")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")