$re = '/^.*\$inline\((.*)\)\$/m';
$str = 'Ez itt egy teszt szöveg $inline(file(p)ath)$ és ) itt folytatódik a szöveg
';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;