package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\@([\w]+\.)?cyber(folks|stores)\.(pl|com|ro|hr)|([\w\W]+\.)?emaillabs\.net\.pl|((local|sp|local-\d+\.cyberadmin)\.)?cyber\-folks\.pl|([\w\W]+\.)?livemailservice\.com|ascio\.com|cfpl\.atlassian\.net|mlsend\.com|satisfactia\.com|zenbox\.pl|avalon\.hr|hekko(\.net)?\.pl|futurehost\.pl|linuxpl\.com`)
var str = []byte(`jira@cfpl.atlassian.net`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}